[lustre-devel] [PATCH 4/5] staging/lustre/obdclass: Combine two seq_printf() calls into one call in lprocfs_rd_state()

Oleg Drokin oleg.drokin at intel.com
Thu Jan 12 22:59:51 PST 2017


On Jan 1, 2017, at 11:38 AM, SF Markus Elfring wrote:

> From: Markus Elfring <elfring at users.sourceforge.net>
> Date: Sun, 1 Jan 2017 16:26:36 +0100
> 
> Some data were printed into a sequence by two separate function calls.
> Print the same data by a single function call instead.
> 
> This issue was detected by using the Coccinelle software.
> 
> Signed-off-by: Markus Elfring <elfring at users.sourceforge.net>
> ---
> drivers/staging/lustre/lustre/obdclass/lprocfs_status.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/drivers/staging/lustre/lustre/obdclass/lprocfs_status.c b/drivers/staging/lustre/lustre/obdclass/lprocfs_status.c
> index 3f6fcab5a1fc..a167cbe8a50e 100644
> --- a/drivers/staging/lustre/lustre/obdclass/lprocfs_status.c
> +++ b/drivers/staging/lustre/lustre/obdclass/lprocfs_status.c
> @@ -853,10 +853,8 @@ int lprocfs_rd_state(struct seq_file *m, void *data)
> 		return rc;
> 
> 	imp = obd->u.cli.cl_import;
> -
> -	seq_printf(m, "current_state: %s\n",
> +	seq_printf(m, "current_state: %s\nstate_history:\n",
> 		   ptlrpc_import_state_name(imp->imp_state));
> -	seq_printf(m, "state_history:\n");

same as in that other patch - this actually makes the code a bit harder to read,
what's the perceived benefit to make a change like this?

> 	k = imp->imp_state_hist_idx;
> 	for (j = 0; j < IMP_STATE_HIST_LEN; j++) {
> 		struct import_state_hist *ish =
> -- 
> 2.11.0



More information about the lustre-devel mailing list