[lustre-devel] [PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool

Greg Kroah-Hartman gregkh at linuxfoundation.org
Fri Jun 23 09:16:31 PDT 2017

On Tue, Jun 20, 2017 at 02:36:37PM +0530, simran singhal wrote:
> This patch changes the type of variable done from int to boolean. As it
> is been used as a boolean in the function sfw_test_rpc_done(). It also
> makes the code more readable and bool data type also requires less
> memory in comparison to int data type.

Are you sure it takes less memory?  What is the difference before and
after your patch?  Don't make claims without having a way to back them
up :)


greg k-h

More information about the lustre-devel mailing list