[Lustre-discuss] build issues with whamcloud

chris (fool) mccraw gently at gmail.com
Tue Jun 28 11:19:37 PDT 2011

i'm sure i'm doing something dumb, but i can't get (git tag
v1_8_6_80 from whamcloud's git) to even configure.  i was trying to
use the build instructions from sun's lustre site

if i'm using a bad version or someone can point me to the place to
download 1.8.6 from sun, i'd be thrilled to try that.  i just heard a
lot of talk about 1.8.6 on this list and was hoping to use it but
couldn't find it at sun.

here's what went down:

autoconf - tried v2.13 and v2.50 and got the same result with both -
errors on first run, success on second run:

root at bigbird49:~/lustre-release# autoconf2.50
configure.ac:6: error: possibly undefined macro: AM_CONDITIONAL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:14: error: possibly undefined macro: AM_INIT_AUTOMAKE
root at bigbird49:~/lustre-release# autoconf2.50
root at bigbird49:~/lustre-release#

then configure --with-linux=/usr/src/linux (which in my case happens
to be a 2.6.32-32 ubuntu-patched kernel source tree)

root at bigbird49:~/lustre-release# ./configure --with-linux=/usr/src/linux
configure: WARNING: unrecognized options: --with-linux
./configure: line 1776: syntax error near unexpected token `LDISKFS_ENABLED,'
./configure: line 1776: `AM_CONDITIONAL(LDISKFS_ENABLED, false)'
root at bigbird49:~/lustre-release#

so there were errors on the autoconf, and configure didn't recognize
with --with-linux directive, and then failed to run anyway.

help?  & thanks in advance!

More information about the lustre-discuss mailing list