[Lustre-discuss] Problem with 1.8 -> 2.1 migration and root_squash

Joan J. Piles jpiles at unizar.es
Mon Mar 12 05:04:56 PDT 2012

Hello all,

We have been (happily) using a lustre 1.8 installation for some time 
now. However, due to a recent acquisition of some Interlagos client 
nodes, we have been forced to install ScientificLinux 6.2 (a clone of 
RHEL 6.2) in order to fully support the new features.

As we found some installation problems with the latest kernel, and 
didn't seem to be a commitment to fully support this configuration, we 
chose to migrate all our infrastructure to newest lustre 2.1, which was 
supposed to be a clear migration path.

However, we found a problem im our MDS which prevented mounting it with 
the new version:

Mar  7 20:03:35 mds01 kernel: LustreError: 
6610:0:(obd_config.c:1140:class_process_proc_param()) home-MDT0000: 
unknown param rootsquash=99:99
Mar  7 20:03:35 mds01 kernel: LustreError: 
6610:0:(obd_config.c:1361:class_config_llog_handler()) Err -38 on cfg 
Mar  7 20:03:35 mds01 kernel: Lustre:    cmd=cf00f 0:home-MDT0000  
Mar  7 20:03:35 mds01 kernel: LustreError: 15c-8: MGC172.16.4.3 at tcp: The 
configuration from log 'home-MDT0000' failed (-38). This may be the 
result of communication errors between this node and the MGS, a bad 
configuration, or other errors. See the syslog for more information.
Mar  7 20:03:35 mds01 kernel: LustreError: 
6124:0:(obd_mount.c:1192:server_start_targets()) failed to start server 
home-MDT0000: -38
Mar  7 20:03:35 mds01 kernel: LustreError: 
6124:0:(obd_mount.c:1723:server_fill_super()) Unable to start targets: -38
Mar  7 20:03:35 mds01 kernel: Lustre: Failing over home-MDT0000

We were able to overcome this using tunefs.lustre --writeconf. However, 
when we try to enable root squash again, we still get errors (we also 
tried without the underscore, just in case, and the results are exactly 
the same):

[root at mds01 ~]# lctl conf_param home.mds.root_squash="99:99"
Make sure cfg_device is set first.
error: conf_param: Function not implemented

In the message logs we see:

Mar 12 13:07:28 mds01 kernel: Lustre: Ignoring unrecognized param 
Mar 12 13:07:28 mds01 kernel: LustreError: 
9959:0:(mgs_handler.c:970:mgs_iocontrol()) setparam err -38

Is it a bug in the way Lustre 2.1 handles old metadata? How should we 
re-enable root squash in our scenario?

Thanks in advance,


Joan Josep Piles Contreras -  Analista de sistemas
I3A - Instituto de Investigación en Ingeniería de Aragón
Tel: 976 76 10 00 (ext. 5454)
http://i3a.unizar.es -- jpiles at unizar.es

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20120312/71315dbf/attachment.htm>

More information about the lustre-discuss mailing list