[Lustre-discuss] Help on installing Lustre 2.1.5 on stock CentOS 6.3

Chan Ching Yu, Patrick cychan at clustertech.com
Mon May 27 08:14:55 PDT 2013

Hi all,

I tried to install Lustre 2.1.5 client RPM (patchless kernel) on a CentOS 6.3 machine. 

However, in Whamcloud download site (http://downloads.whamcloud.com/public/lustre/latest-maintenance-release/el6/client/RPMS/x86_64/), 
I can only find the binary RPMs for kernel 2.6.32-279.19.1, while kernel version on my stock CentOS6.3 is 2.6.32-279.

As the kernel version does not match, I tried to build from source RPM, the rpmbuild is fine:

# rpmbuild --rebuild lustre-client-2.1.5-2.6.32_279.19.1.el6.x86_64.src.rpm
# cd rpmbuild/RPMS/x86_64/

But dependencies error comes out when I install Lustre client RPMs:

# rpm -ivh lustre-2.1.5-2.6.32_279.el6.x86_64.x86_64.rpm lustre-modules-2.1.5-2.6.32_279.el6.x86_64.x86_64.rpm lustre-tests-2.1.5-2.6.32_279.el6.x86_64.x86_64.rpm

error: Failed dependencies:
        lustre-backend-fs is needed by lustre-modules-2.1.5-2.6.32_279.el6.x86_64.x86_64

As I know, Lustre client does not need lustre-backend-fs. Why does this error occur? Thx.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20130527/20b333c8/attachment.htm>

More information about the lustre-discuss mailing list