[Lustre-discuss] Lustre Client building problem on Centos 6.5

Andrew Holway andrew.holway at gmail.com
Mon Jul 21 04:43:42 PDT 2014

On 21 July 2014 10:25, Sean Brisbane <s.brisbane1 at physics.ox.ac.uk> wrote:

>  Hi Andrew,
> To get l2.5 to build on el6.5 I needed to disable building the server
> modules.
> rpmbuild --rebuild --define "lustre_name lustre-client" --define
> "configure_args --disable-server --enable-client" --without servers
> lustre-client-2.5.2-2.6.32_431.17.1.el6.x86_64.src.rpm

Hi Sean,

Yea I have tried various permutations of the command, all to no avail.  I
am trying the following:

rpmbuild --rebuild --without servers --define 'kversion $(uname -r)'
--define 'kdir /usr/src/kernels/2.6.32-431.20.3.el6.x86_64/' --rebuild

And see the same error:

+ cp /root/rpmbuild/BUILD/lustre-2.5.1/lustre/obdclass/llog_test.ko

cp: cannot create regular file
No such file or directory

error: Bad exit status from /var/tmp/rpm-tmp.rJHw4x (%install)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20140721/3ff759bb/attachment.htm>

More information about the lustre-discuss mailing list