[lustre-discuss] Lustre 2.7 deployment issues

Ray Muno muno at umn.edu
Thu Dec 3 07:13:35 PST 2015

I am trying to set up a test deployment of Lustre 2.7.

I pulled RPMS from http://lustre.org/download/ and installed them on a 
set of server running Scientific Linux 6.6 which seems to be a proper OS 
for deployment.  Everything installs and I can format the filesystems on 
the MDS (1) and OSS (2) servers. When I try and mount the OST files 
systems, I get communication errors. I can "lctl ping" the servers from 
each other, but cannot establish communication between the MDS and OSS.

The installation is on servers connected over Infiniband (Qlogic DDR 4X).

In trying to diagnose the issues related to the error messages, I found 
mention in some list discussions that o2ib is broken in the 
2.6.32-504.8.1 kernel.

After much frustration, I pulled a nightly build from 
build.hpdd.intel.com (kernel 2.6.32-573.8.1.el6_lustre.g8438f2a.x86_64) 
and tried the same set up.  Everything worked as I expected.

Am I missing something? Is the default release pointed to at 
https://downloads.hpdd.intel.com/ for 2.7 broken in some way? Is it just 
the hardware I am trying to deploy against?

I can provide specifics about the errors I see, I am just posting this 
to make sure I am pulling the Lustre RPM's from the proper source.


  Ray Muno

                           University of Minnesota
  Aerospace Engineering and Mechanics         Mechanical Engineering
  110 Union St. S.E.                          111 Church Street SE
  Minneapolis, MN 55455                       Minneapolis, MN 55455

More information about the lustre-discuss mailing list