[lustre-discuss] Building Lustre client from Git pull fails when --with-o2ib=no parameter specified to ./configure

Sean Caron scaron at umich.edu
Wed Jul 15 13:41:41 PDT 2015

Hi all,

Sorry for the cross-post from the Intel Lustre list but hoping I might get
more traction here...

Working with my Git pull of the Intel Lustre codebase from a few weeks ago,
I'm trying to build the client on Ubuntu 12.04 with a house-built 3.4.61

Running through the build procedure roughly outlined in bug report LU-1706
but with some changes since the last time I tried:

# tar xvfp lustre-release.tar
# cd lustre-release
# sh autogen.sh
# ./configure --disable-server --with-o2ib=no  --with-linux=/usr/src/linux
# make debs

Build fails at the module stage with the following error:

configure: error: bad --with-o2ib path
make[2]: *** [kdist_config] Error 1
make[2]: Leaving directory `/usr/src/lustre
make[1]: *** [kdist_build] Error 2
make[1]: Leaving directory `/usr/src/lustre
See /usr/src/lustre-release/debian/tmp/modules-deb/var_cache_modass/lustre.buildlog.
for details.
make: *** [debs] Error 7

It appears it's not recognizing --with-o2ib=no as outlined in ./configure
--help or i.e. bug report LU-5953.

If I take that out, build chokes because it can't find Infiniband stuff
which I suppose is to be expected since this site is not using Infiniband.

I've tried moving the parameter around towards the beginning of the
./configure parameter list or towards the end and it doesn't seem to make a

Noting the place where the install hung; I went in and modified line 338 in


to completely remove $(IB_OPTIONS) from the ./configure statement on that
line; the build still fails, but in a way that's not really clear what the
cause is:

export KPKG_DEST_DIR="$(pwd)/.." && \
version=$(sed -ne '1s/^lustre (\(.*\)).*$/\1/p' debian/changelog) && \
rm -rf debian/tmp/modules-deb && \
mkdir debian/tmp/modules-deb && \
pushd debian/tmp/modules-deb && \
dpkg -x ../../../../lustre-source_${version}_all.deb $(pwd) && \
mkdir usr_src/ && \
tar -C usr_src/ -xjf usr/src/lustre.tar.bz2 && \
chmod 755 usr_src/modules/lustre/debian/rules && \
mkdir -p usr_share_modass && \
ln -s /usr/share/modass/include/ usr_share_modass/ && \
ln -s /usr/share/modass/packages/ usr_share_modass/ && \
echo "lustre" > usr_share_modass/compliant.list && \
export MA_DIR=$(pwd)/usr_share_modass && \
KVERS=${KVERS:-} && \
[ "x" != "x" ] && \
export IB_OPTIONS="--with-o2ib=" && \
export KSRC_TREE= && \
KSRC=${KSRC:-} && \
m-a build ${KSRC:+-k $KSRC} ${KVERS:+-l $KVERS} -i -u $(pwd) lustre && \
popd && \
VER=$(sed -ne '1s/^lustre (\(.*-[0-9][0-9]*\)).*$/\1/p' debian/changelog)
&& \
mkdir -p debs && \
mv ../linux-patch-lustre_${VER}_all.deb ../lustre-dev_${VER}_*.deb \
   ../lustre-source_${VER}_all.deb ../lustre-tests_${VER}_*.deb \
   ../lustre-utils_${VER}_*.deb ../lustre_${VER}.dsc \
   ../lustre_${VER}_*.changes ../lustre_${VER}.tar.gz \
   ../lustre-client-modules-${KVERS}_${VER}_*.deb debs/
/usr/src/lustre-release/debian/tmp/modules-deb /usr/src/lustre-release
make: *** [debs] Error 1

Is this a legit bug? Am I missing something here? Maybe resolved if I do a
fresh Git pull? Any suggestions would be a huge help.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20150715/2f010a7e/attachment.htm>

More information about the lustre-discuss mailing list