[lustre-discuss] Lustre doesn't use new OST

Mohr Jr, Richard Frank (Rick Mohr) rmohr at utk.edu
Wed Nov 11 11:15:07 PST 2015

> On Nov 10, 2015, at 6:52 AM, Massimo Sgaravatto <massimo.sgaravatto at pd.infn.it> wrote:
> Hello
> Let me resurrect this old thread concerning the problem of OST not used if there are deactivated OSTs (see below for details)
> I created a small testbed with a Lustre 2.5.3 server (MGS + MDT + OSS) and a Lustre 2.5.3 client.
> I reproduced the problem creating a Lustre filesystem with:
> - OST-0 OST-1 and OST-5 active
> - OST-2, OST-3, OST-4 deactived
> and I see that files are not written in OST-5.
> I then tried to update the Lustre server machine to Lustre v. 2.7.0 (while the client keeps running Lustre v. 2.5.3): the problem is still there.
> I then tried to also update the client to Lustre v. 2.7.0 and it looks like this fixes the problem.
> Is this expected ? I thought the problem was in the server side ...

If the problem was related to LU-5778, then I would expect it to be purely a server side issue.  So either I misread something in the bug report, or this is a different issue (although it is good to know that upgrading both the server and the client helped).

Rick Mohr
Senior HPC System Administrator
National Institute for Computational Sciences

More information about the lustre-discuss mailing list