[lustre-discuss] ZFS version for lustre-2.8 binaries?

Nathan Smith sminatha at ohsu.edu
Tue Apr 12 08:21:15 PDT 2016

In doing a test install of vanilla Lustre 2.8 [0] and zfs- I
received the symbol mismatch error when attempting to start lustre:

    osd_zfs: disagrees about version of symbol *

I checked the release notes [1] and saw that support was bumped to, so I tried that, but received the same error. I saw in jira
that there were other subsequent versions bumps of zfs tagged for 2.8,
and it is at least up to [2]

Long story short: I built lustre 2.8 from source against spl/zfs and everything works well. But does anyone know the compatible
version for the "official" 2.8 binaries? Thanks.

[0] https://downloads.hpdd.intel.com/public/lustre/latest-feature-release/el7.2.1511/server/
[1] https://wiki.hpdd.intel.com/display/PUB/Changelog+2.8
[2] https://jira.hpdd.intel.com/browse/LU-7316

Nathan Smith
Research Systems Engineer
Advanced Computing Center
Oregon Health & Science University

More information about the lustre-discuss mailing list