[lustre-discuss] Still having problems Lustre 2.8 Centos 7.2

Phill Harvey-Smith p.harvey-smith at warwick.ac.uk
Tue Sep 27 07:12:04 PDT 2016

Hi all

I'm still having problems trying to setup lustr 2.8 on Centos 7.2. I 
think part of the problem is that the documentation at : 
http://lustre.org/documentation/ seems to be way out of date, when it 
comes to setting up lustre with zfs.

Also chapter 9 of the documentation talks about using lnetctl to setup 
the lustre network, this doesn't seem to exist / have been installed.

OK, this is what I have done so far.

Setup two servers, oric and lynx.
oric will be the mgs/mgt server
lynx will be the oss server.

Both now have the correct versions of zfs and the lustre packages installed.

both servers have a zfs pool called testpool.

on the mgs I have tried to create the combined mgs/mdt with :

mkfs.lustre --reformat --fsname=test --mgs --mdt --index=0 
--backfstype=zfs      testpool/mgt_test

That went without hitch, the docs say to try and mount this, however 
doing so following the documentation will not allow this to be mounted.

Tom Crowe, suggested that I needed to edit /etc/ldev.conf I have done 
that and added the line :

test-mds1 - test-MDT0000 zfs:testpool/mgt_test

typing service lustre start seems not to return any errors, and there's 
also nothing in /var/log/messages that seems to indicate failure.

Now on to the oss lynx :

Again zfs / lustre packages installed and testpool setup.

I have tried to make the oss with :

  mkfs.lustre --reformat --ost --fsname=test --mgsnode=137.205.xxx.xxx 
--index=0 --backfstype=zfs    testpool/test_ost

Again it returned without an error :

    Permanent disk data:
Target:     test:OST0000
Index:      0
Lustre FS:  test
Mount type: zfs
Flags:      0x62
               (OST first_time update )
Persistent mount opts:
Parameters: mgsnode= at tcp

mkfs_cmd = zfs create -o canmount=off -o xattr=sa testpool/test_ost
Writing testpool/test_ost properties
   lustre:mgsnode= at tcp

Again /etc/ldev.conf modified and added :

test test test-OST0000 zfs:testpool/test_ost

This should have completed the setup however I can't mount the 
filesystem from a client machine :

  mount -t lustre at tcp0:/test /mnt
mount.lustre: mount at tcp0:/test at /mnt failed: 
Input/output error
Is the MGS running?

Can anyone help.

Alternately is there a simple walkthrough of setting lustre up with zfs 
that I can try to get things going.



More information about the lustre-discuss mailing list