[lustre-discuss] Still having problems Lustre 2.8 Centos 7.2

Dilger, Andreas andreas.dilger at intel.com
Wed Sep 28 10:00:17 PDT 2016

On Sep 27, 2016, at 08:12, Phill Harvey-Smith <p.harvey-smith at warwick.ac.uk> wrote:
> Hi all
> I'm still having problems trying to setup lustr 2.8 on Centos 7.2. I think part of the problem is that the documentation at : http://lustre.org/documentation/ seems to be way out of date, when it comes to setting up lustre with zfs.

Updates to the manual are welcome, or at least an LUDOC ticket with details.

> Also chapter 9 of the documentation talks about using lnetctl to setup the lustre network, this doesn't seem to exist / have been installed.

That was an oversight during the 2.8.0 build and was fixed afterward.
> OK, this is what I have done so far.
> Setup two servers, oric and lynx.
> oric will be the mgs/mgt server
> lynx will be the oss server.
> Both now have the correct versions of zfs and the lustre packages installed.
> both servers have a zfs pool called testpool.
> on the mgs I have tried to create the combined mgs/mdt with :
> mkfs.lustre --reformat --fsname=test --mgs --mdt --index=0 --backfstype=zfs      testpool/mgt_test
> That went without hitch, the docs say to try and mount this, however doing so following the documentation will not allow this to be mounted.

The MGS _must_ be mounted if the filesystem is going to work, so trying to
mount the client is pointless until this has been done.  Did you follow the
advice from Chris Morrone in reply to your previous email and check what is
shown from dmesg, or in /var/log/messages when you try to mount?

You need something like:

mds# mkdir -p /mnt/mgt_test
mds# mount -t lustre testpool/mgt_test /mnt/mgt_test

(minor note, I would have named this dataset "mdt_test" instead of "mgt_test"
for a combined MDS/MGS).

> Tom Crowe, suggested that I needed to edit /etc/ldev.conf I have done that and added the line :
> test-mds1 - test-MDT0000 zfs:testpool/mgt_test
> typing service lustre start seems not to return any errors, and there's also nothing in /var/log/messages that seems to indicate failure.
> Now on to the oss lynx :
> Again zfs / lustre packages installed and testpool setup.
> I have tried to make the oss with :
> mkfs.lustre --reformat --ost --fsname=test --mgsnode=137.205.xxx.xxx --index=0 --backfstype=zfs    testpool/test_ost
> Again it returned without an error :
>   Permanent disk data:
> Target:     test:OST0000
> Index:      0
> Lustre FS:  test
> Mount type: zfs
> Flags:      0x62
>              (OST first_time update )
> Persistent mount opts:
> Parameters: mgsnode= at tcp
> mkfs_cmd = zfs create -o canmount=off -o xattr=sa testpool/test_ost
> Writing testpool/test_ost properties
>  lustre:version=1
>  lustre:flags=98
>  lustre:index=0
>  lustre:fsname=test
>  lustre:svname=test:OST0000
>  lustre:mgsnode= at tcp
> Again /etc/ldev.conf modified and added :
> test test test-OST0000 zfs:testpool/test_ost

You still need to mount the OST, and it needs to connect to the MGS on the
first mount before it can be used.

Cheers, Andreas

> This should have completed the setup however I can't mount the filesystem from a client machine :
> mount -t lustre at tcp0:/test /mnt
> mount.lustre: mount at tcp0:/test at /mnt failed: Input/output error
> Is the MGS running?
> Can anyone help.
> Alternately is there a simple walkthrough of setting lustre up with zfs that I can try to get things going.
> Cheers.
> Phill.
> _______________________________________________
> lustre-discuss mailing list
> lustre-discuss at lists.lustre.org
> http://lists.lustre.org/listinfo.cgi/lustre-discuss-lustre.org

More information about the lustre-discuss mailing list