[lustre-discuss] lustre client not able to lctl ping or mount

Mohr Jr, Richard Frank (Rick Mohr) rmohr at utk.edu
Tue Sep 4 09:40:14 PDT 2018

> On Sep 4, 2018, at 12:12 PM, Pak Lui <pak.lui at linaro.org> wrote:
> I have tried "map_on_demand=16" to the "/etc/modprobe.d/ko2iblnd.conf" that was suggested. Also tried "map_on_demand=0" as suggested here: http://wiki.lustre.org/Optimizing_o2iblnd_Performance
> /etc/modprobe.d/ko2iblnd.conf
> alias ko2iblnd-opa ko2iblnd
> # tried, as suggested in  http://wiki.lustre.org/Optimizing_o2iblnd_Performance
> #options ko2iblnd-opa peer_credits=128 peer_credits_hiw=64 credits=1024 ntx=2048 map_on_demand=0 fmr_pool_size=2048 fmr_flush_trigger=512 fmr_cache=1 conns_per_peer=4
> options ko2iblnd-opa peer_credits=128 peer_credits_hiw=64 credits=1024 ntx=2048 map_on_demand=16 fmr_pool_size=2048 fmr_flush_trigger=512 fmr_cache=1 conns_per_peer=4
> install ko2iblnd /usr/sbin/ko2iblnd-probe

The lines with ko2iblnd-opa are intended for OmniPath hardware.  Since you are using IB, you will want to just set your options like this:

options ko2iblnd peer_credits=…, etc.

Have you verified that the firewall is not running?  It’s possible a firewall might be allowing ping traffic but blocking the port needed by Lustre.

Rick Mohr
Senior HPC System Administrator
National Institute for Computational Sciences

More information about the lustre-discuss mailing list