[lustre-discuss] Error in lfsck: "NOT IMPLEMETED YET"

João Carlos Mendes Luís jonny at corp.globo.com
Mon Jul 22 15:08:07 PDT 2019


     I'm running some lab tests with lustre 2.12.2 in Oracle Linux 
Server release 7.6.  Last test I did was about migration and MDT 
splitting.  I started with a MGS+MDS node, and two OSS nodes, and one of 
the tests was to create two more MDSs and migrate data between then, 
until, after some time, I could delete the original MDS.  But something 
happened in the middle and the servers panicked/rebooted.

     I am now in what appears to be an lfsck bug.  After many other 
tests, I run lfsck_start, and after some time get this message on the nodes:


*[Mon Jul 22 17:42:25 2019] LustreError: 
24107:0:(osd_index.c:1872:osd_index_it_get()) NOT IMPLEMETED YET (move 
to 0x2481000002000000)*


*[Mon Jul 22 17:40:29 2019] LustreError: 
31558:0:(osd_index.c:1872:osd_index_it_get()) NOT IMPLEMETED YET (move 
to 0xa41300c002000000)*


*[Mon Jul 22 17:40:32 2019] LustreError: 
8935:0:(osd_index.c:1872:osd_index_it_get()) NOT IMPLEMETED YET (move to 

     And for current lfsck status, I run *lctl get_param *.*.lfsck* | 
grep -E 'status|\.lfsck_lay|\.lfsck_name'*


**status: completed**
**status: partial*


**status: completed**
**status: partial**
**status: completed*


**status: completed**
**status: partial**
**status: completed*

     Is this a known bug?  How do I fix these "partial" lsfck runs?

     Thanks for any help,


*João Carlos Mendes Luís*
*Senior DevOps Engineer*
jonny at corp.globo.com <mailto:jonny at corp.globo.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20190722/32fa7bd4/attachment.html>

More information about the lustre-discuss mailing list