[lustre-discuss] lfsck namespace doesn't stop and I cancel it

Fernando Perez fperez at icm.csic.es
Wed Jun 26 05:06:47 PDT 2019

Sorry, the command that I runned to start the lfsck is the following:

lctl lfsck_start -M lustre-MDT0000 -t namespace

When I try to run the stop command:

lctl lfsck_stop -M lustre-MDT0000

The output is:

Fail to stop LFSCK: Operation now in progress


Fernando Pérez
Institut de Ciències del Mar (CSIC)
Departament Oceanografía Física i Tecnològica
Passeig Marítim de la Barceloneta,37-49
08003 Barcelona
Phone:  (+34) 93 230 96 35

On 6/26/19 1:58 PM, Fernando Perez wrote:
> Dear lustre users,
> I tried to run a lfsck namespace in our lustre filesystem, lustre 
> 2.10.7, and the lfsck never ends and I can't stop it using the lctl 
> lfsck_stop command.
> I tried to kill the lfsck process, stop lustre, reboot the metadata 
> server, and when I mount the combined mdt + mgs the lfsck starts again 
> automatically.
> How can I stop the lfsck namespace process?
> The commands that I runned are the following:
> Start the lfsck namespace:
> lctl lfsck_query -t namespace -M lustre-MDT0000
> Try to stop the lfsck because it never ends:
> lctl lfsck_stop -M lustre-MDT0000
> Regards.

More information about the lustre-discuss mailing list