[lustre-discuss] lfs df showing a "D" after an ost

Kurt Strosahl strosahl at jlab.org
Thu Jun 27 10:35:00 PDT 2019


   an update.  The client I was using was 2.10, so it didn't have the D option in its man page.  However I'm not clear on how to update that D status.  The underlying OST shows as fine.

some more digging and I was able to find it... I had to look on the OSS not the MGS.


From: Kurt Strosahl
Sent: Thursday, June 27, 2019 1:23 PM
To: lustre-discuss at lists.lustre.org
Subject: lfs df showing a "D" after an ost

Good Afternoon,

    I've got a new 2.12 lustre file system up, and when I run a lfs df it shows a D next to one of the OSTs.  I'm not quite sure what has put that D there.  I did do a disk replacement test on that OST yesterday, so I'm thinking that it is some sort of marker for the underlying zpool being degraded, but the rebuild finished more then 24 hours ago.

Looking through the manual (section 13.7) there is a reference to setting OSTs to a degraded state, but when I run the get_param it returns an error

lctl get_param obdfilter.*.degraded
error: get_param: param_path 'obdfilter/*/degraded': No such file or directory

lfs df -h
UUID                       bytes        Used   Available Use% Mounted on
lustre19-MDT0000_UUID        2.5T       12.1M        2.5T   0% /lustre19[MDT:0]
lustre19-OST0000_UUID       66.3T        5.4T       60.8T   8% /lustre19[OST:0] D
lustre19-OST0001_UUID       66.3T       19.0M       66.3T   0% /lustre19[OST:1]
lustre19-OST0002_UUID       66.3T        4.4T       61.8T   7% /lustre19[OST:2]


Kurt J. Strosahl
System Administrator: Lustre, HPC
Scientific Computing Group, Thomas Jefferson National Accelerator Facility
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20190627/5ee380da/attachment-0001.html>

More information about the lustre-discuss mailing list