[lustre-discuss] Stray files after failed lfs_migrate

Angelos Ching angelosching at clustertech.com
Tue Mar 2 02:22:18 PST 2021

Dear all,

I was dealing with some OST migration using lfs_migrate and things went 
mostly fine albeit for a few files that might have been in use during 
the migration:

> # ls
> ls: cannot access ibleTHWm: No such file or directory
> ls: cannot access ib7rP0qy: No such file or directory
> ls: cannot access ib3AQ9vK: No such file or directory
> ls: cannot access ib30N1p9: No such file or directory
> ib30N1p9  ib3AQ9vK  ib7rP0qy  ibleTHWm
> # stat ib30N1p9
> stat: cannot stat ‘ib30N1p9’: No such file or directory
> # lfs getstripe ib30N1p9
> ib30N1p9
> lmm_stripe_count:  1
> lmm_stripe_size:   1048576
> lmm_pattern:       raid0
> lmm_layout_gen:    0
> lmm_stripe_offset: 1
>     obdidx         objid         objid         group
>          1          71909438        0x449403e 0
The files couldn't be stat'ed but still returns upon lfs getstripe.

The same error appears on all clients and I've tried unmounting and 
remounting the MDT on the server side already.

Any idea what might have been corrupted and what could be the fix?


Angelos Ching
ClusterTech Limited

Tel     : +852-2655-6138
Fax     : +852-2994-2101
Address	: Unit 211-213, Lakeside 1, 8 Science Park West Ave., Shatin, Hong Kong

Got praises or room for improvements? http://bit.ly/TellAngelos

The information contained in this e-mail and its attachments is confidential and
intended solely for the specified addressees. If you have received this email in
error, please do not read, copy, distribute, disclose or use any information of
this email in any way and please immediately notify the sender and delete this
email. Thank you for your cooperation.

More information about the lustre-discuss mailing list