[lustre-discuss] The MDT MDS and OSS wont mount (case resolved)

Abdeslam Tahari abeslam at gmail.com
Thu May 20 11:17:30 PDT 2021

  Hello Ms everybody

I had a case that i had solved

Brief description of the case:i couldn't not mount the MDT ,MDS and the

when i executed the command # mount -t lustre /dev/sdX   /YY
The result = it does in fact mount the lustre file system four about 2 to 3
seconds after that nothing
Th command # lctl dl  ===> does return nothing

I suspected the lustre network ===> but everything was ok

I run the debug command just straight away after executing the
mounting command in the following order

# mount -t lustre /dev/X  /YY

# lctl dk to have the debug output to see what is happening

i had a huge output and many lines , but i resume ; which catch my
attention was

specially this portion, or these few lines:
lustre-MDT0000: index object [0x200000003:0x36:0x0] (8/32) registered
Unassign mgc disk
Server sb, dev=41
server put_super lustre-MDT0000
end config log lustre-client (0)
setting import lustre-MDT0000_UUID INVALID*
removing pingable import
setting import lustre-MDT0000_UUID INVALID

This means that it does complain about the UUID

I found the problem ,the solution was checking the UUID of the disk that i
wanted to mount and it is UUID in the fstab file

the disk changed it is UUID because i have formatted it many times (lustre
file system and just an ext4 filesystem as well)

after checking the UUIDs were different so, i have to pick up the correct
one from the fstab file (that is the first one with which i have formatted
the disk of lustre file system)

i tried as well with the command # tunefs.lustre --writeconf  /dev/sdXX
========> no results (it didn't in fact erase nothing, no changes.)

the lustre file system just won't mount

At last the solution:

-use tune2fs as follow#*tune2fs -O uninit_bg -m 1 -U
5b611acd-e5f8-4976-a063-dd867cdbbc62 /dev/sdX*

The UUID used here is the one in the fstab file

if you have an error message or it just won't change the UUID  (then you
have to format the disk to ext4 , if you don't have any data on it).

Finally you can mount the MDS,MDT and the OSSs with no problem.

That was all.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20210520/e137d40c/attachment.html>

More information about the lustre-discuss mailing list