[lustre-discuss] can't install Lustre 2.12.7

Riccardo Veraldi riccardo.veraldi at cnaf.infn.it
Thu Sep 23 18:13:30 PDT 2021


I am not successful installing lustre 2.12.7 I run into a problem with 
dkms on RHEL 7.9

kernel 3.10.0-1160.42.2.el7.x86_64

I am using rpm from 

the lustre dkms module fails building, seems like something is missing 
or there is a wrong path somewhere so that the proper headers are not 
found, but I Could not figure out what. I Tried both with zfs-0.7.13 and 
zfs-0.8.6 but same result. So I am missing something

Any hints ? I am stuck.

ZFS is:


yum install lustre-dkms
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package lustre-zfs-dkms.noarch 0:2.12.7-1.el7 will be installed
--> Processing Dependency: lustre-osd-zfs-mount for package: 
--> Running transaction check
---> Package lustre-osd-zfs-mount.x86_64 0:2.12.7-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

  Package                              Arch 
Version                       Repository              Size
  lustre-zfs-dkms                      noarch 
2.12.7-1.el7                  lustre                  12 M
Installing for dependencies:
  lustre-osd-zfs-mount                 x86_64 
2.12.7-1.el7                  lustre                  12 k

Transaction Summary
Install  1 Package (+1 Dependent package)

Total download size: 12 M
Installed size: 38 M
Is this ok [y/d/N]: y
Downloading packages:
(1/2): lustre-osd-zfs-mount-2.12.7-1.el7.x86_64.rpm |  12 kB  00:00:00
(2/2): lustre-zfs-dkms-2.12.7-1.el7.noarch.rpm |  12 MB  00:00:00
Total 26 MB/s |  12 MB  00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
   Installing : lustre-osd-zfs-mount-2.12.7-1.el7.x86_64 1/2
   Installing : lustre-zfs-dkms-2.12.7-1.el7.noarch 2/2
Loading new lustre-zfs-2.12.7 DKMS files...
Building for 3.10.0-1160.42.2.el7.x86_64
Building initial module for 3.10.0-1160.42.2.el7.x86_64
configure: WARNING:

Disabling ldiskfs support because complete ext4 source does not exist.

If you are building using kernel-devel packages and require ldiskfs
server support then ensure that the matching kernel-debuginfo-common
and kernel-debuginfo-common-<arch> packages are installed.

./configure: line 33341: test: zfs: integer expression expected
configure: error:

Required zfs osd cannot be built due to missing zfs development headers.

Support for zfs can be enabled by downloading the required packages for your
distribution.  See http://zfsonlinux.org/ to determine is zfs is 
supported by
your distribution.

Error! Bad return status for module build on kernel: 
3.10.0-1160.42.2.el7.x86_64 (x86_64)
Consult /var/lib/dkms/lustre-zfs/2.12.7/build/make.log for more information.
warning: %post(lustre-zfs-dkms-2.12.7-1.el7.noarch) scriptlet failed, 
exit status 10
Non-fatal POSTIN scriptlet failure in rpm package 
   Verifying  : lustre-osd-zfs-mount-2.12.7-1.el7.x86_64 1/2
   Verifying  : lustre-zfs-dkms-2.12.7-1.el7.noarch 2/2

   lustre-zfs-dkms.noarch 0:2.12.7-1.el7

Dependency Installed:
   lustre-osd-zfs-mount.x86_64 0:2.12.7-1.el7

cat /var/lib/dkms/lustre-zfs/2.12.7/build/make.log
DKMS make.log for lustre-zfs-2.12.7 for kernel 
3.10.0-1160.42.2.el7.x86_64 (x86_64)
Thu Sep 23 17:42:12 PDT 2021
make: *** No targets specified and no makefile found.  Stop.

More information about the lustre-discuss mailing list