[lustre-discuss] 2.14 against mofed

Nathan Dauchy ndauchy at nvidia.com
Mon Mar 7 09:28:38 PST 2022


Likely your issue will be resolved in 2.15.  You could try applying the patch from here:
Build lustre on MOFED 5.5


-----Original Message-----
From: lustre-discuss <lustre-discuss-bounces at lists.lustre.org> On Behalf Of Michael DiDomenico via lustre-discuss
Sent: Monday, March 7, 2022 10:16 AM
To: lustre-discuss <lustre-discuss at lists.lustre.org>
Subject: Re: [lustre-discuss] 2.14 against mofed

External email: Use caution opening links or attachments

and adding  --with-o2ib=/usr/src/ofa_kernel/x86_64/2.10.0-1160.59.1.el7.x86_64
seems to have at least allowed configure to move forward and the subsequent make passed.  that's as far as i can get today, i'll try mounts later

On Mon, Mar 7, 2022 at 12:07 PM Michael DiDomenico <mdidomenico4 at gmail.com> wrote:
> digging into this a little further, it looks like
> from lustre-release/lnet/autoconf/lustre-lnet.m4
> O2IBPATHS=$(eval $OFED_INFO | egrep -w 
> 'mlnx-ofed-kernel-dkms|mlnx-ofa_kernel-devel|compat-rdma-devel|kernel-ib-devel|ofa_kernel-devel'
> | xargs $LSPKG | grep '\(/openib\|/ofa_kernel/default\|/ofa_kernel\)$'
> | head -n1)
> this is the line that's failing for me.  the first egrep returns 
> mlnx-ofa_kernel-devel, which is piped to rpm -ql, but the second grep 
> does not return anything
> On Mon, Mar 7, 2022 at 11:07 AM Michael DiDomenico 
> <mdidomenico4 at gmail.com> wrote:
> >
> > has anyone compiled 2.14 against the latest mofed  i 
> > just tried, but it kicked out with unable to find the ofed sources.
> > previous build was 2.14 against mofed 5.4- which worked fine
lustre-discuss mailing list
lustre-discuss at lists.lustre.org

More information about the lustre-discuss mailing list