[lustre-discuss] lustre installation on debian 11

Bedosti Francesco bedosti at ira.inaf.it
Wed Mar 16 04:52:08 PDT 2022

thank you for the prompt reply!

On 16/03/22 09:46, Shaun Tancheff via lustre-discuss wrote:
> On 3/16/22 00:23, Bedosti Francesco wrote:
>> Dear all,
>> I'm trying to install Lustre client (version 2.15.0-RC2, but seems that older releases give same results) on Debian 11 hosts with kernel version 5.10.0-12
>> I used Lustre extensively on Debian 10 without problems in the past.
>> The build of packages goes well with:
>> sh autogen.sh && ./configure --disable-server --with-linux=/usr/src/linux-headers-$(uname -r) && make debs
>> sh autogen.sh && ./configure --disable-server --with-linux=/usr/src/linux-headers-$(uname -r) && make dkms-debs
> I am surprised this build worked, the includes in the /usr/src/linux-headers-<version>-common are needed for the build to work, I would expect exactly the error in files you had attached.
> Perhaps the contents of /usr/src/linux-headers-$(uname -r) were fixed to include parts of -common?

yes, sorry
I should have stated that I copied /usr/src/linux-headers-5.10.0-12-common/include/acpi in /usr/src/linux-headers-5.10.0-12-amd64/include/acpi

> An alternative (for building) is:
> sh autogen.sh && ./configure --disable-server --with-linux=/usr/src/linux-headers-<version>-common --with-linux-obj=/usr/src/linux-headers-$(uname -r)  && make dkms-debs
> However the resulting dkms packages will not pickup the linux/obj fix.
> I pushed a patch that fixes the configure for Debian so the dkms build should succeed.
> https://review.whamcloud.com/46836

with the patch I can now build the .debs without any system modification

but when installing them it complains that some headers cannot be found
I tried to fix doing:
ln -vs /usr/src/linux-headers-5.10.0-12-common/include/uapi/linux /usr/src/linux-headers-5.10.0-12-amd64/arch/x86/include/uapi/
ln -vs /usr/src/linux-headers-5.10.0-12-common/include/uapi/asm-generic /usr/src/linux-headers-5.10.0-12-amd64/arch/x86/include/uapi/
ln -vs /usr/src/linux-headers-5.10.0-12-common/include/uapi/video /usr/src/linux-headers-5.10.0-12-amd64/arch/x86/include/uapi/

ln -vs /usr/src/linux-headers-5.10.0-12-common/include/vdso /usr/src/linux-headers-5.10.0-12-amd64/arch/x86/include/
ln -vs /usr/src/linux-headers-5.10.0-12-common/include/asm-generic /usr/src/linux-headers-5.10.0-12-amd64/arch/x86/include/
ln -vs /usr/src/linux-headers-5.10.0-12-common/include/video /usr/src/linux-headers-5.10.0-12-amd64/arch/x86/include/

then repeating configure it complained:

configure: LNet kernel checks
checking whether to enable tunable backoff TCP support... yes
checking if Linux kernel has tunable backoff TCP support... no
checking whether to use Compat RDMA... no
configure: error: no OFED nor kernel OpenIB gen2 headers present

I repeated configure adding -with-o2ib=no and then it completes without errors

but when launching make it gives:
In file included from /var/lib/dkms/lustre-client-modules/2.15.0-RC2-12-g06134ff/build/lnet/include/lnet/lib-lnet.h:46,
                  from /var/lib/dkms/lustre-client-modules/2.15.0-RC2-12-g06134ff/build/libcfs/libcfs/module.c:55:
/var/lib/dkms/lustre-client-modules/2.15.0-RC2-12-g06134ff/build/lnet/include/lnet/lib-types.h: In function ‘lnet_nl_send_error’:
/var/lib/dkms/lustre-client-modules/2.15.0-RC2-12-g06134ff/build/lnet/include/lnet/lib-types.h:1330:2: error: too few arguments to function ‘netlink_ack’
  1330 |  netlink_ack(msg, nlh, error);
       |  ^~~~~~~~~~~
In file included from /usr/src/linux-headers-5.10.0-12-common/arch/x86/include/uapi/linux/neighbour.h:6,
                  from include/linux/netdevice.h:46,
                  from /usr/src/linux-headers-5.10.0-12-common/include/net/sock.h:46,
                  from /var/lib/dkms/lustre-client-modules/2.15.0-RC2-12-g06134ff/build/libcfs/libcfs/module.c:39:
include/linux/netlink.h:149:6: note: declared here

many thanks

More information about the lustre-discuss mailing list