[lustre-discuss] how to unsquash users

Julien Rey julienrey76 at gmail.com
Fri May 20 07:57:36 PDT 2022

Hello everyone,

We are running lustre 2.12.7 and today I tried to set up a few nodemaps 
so as to restrict access to an unique user (seamless user with uid/gid 
3669) to a subdirectory (/webservices/seamless) from a range of machines 

Here's what I did so far :

lctl nodemap_add seamless

lctl nodemap_add_range --name seamless --range 10.0.1.[35-38]@tcp

lctl nodemap_modify --name seamless --property trusted --value 1

lctl nodemap_add_idmap --name seamless --idtype uid --idmap 3669:3669

lctl nodemap_add_idmap --name seamless --idtype gid --idmap 3669:3669

lctl nodemap_set_fileset --name seamless --fileset '/webservices/seamless'

lctl nodemap_activate 1

However, when I tried to log on one of the machine NOT in the 
10.0.1.[35-38] range with my user account (uid 2154), my home directory 
ownership got immediately squashed to:

drwx------ 12 nobody      nobody       4096 Apr  5 17:11 rey

So I immediatly deactivated the nodemaps using :

lctl nodemap_activate 0

However, the directory ownership remains nobody/nobody and I can no 
longer log in.

Does anyone know how to revert this ? And what was wrong with my 
nodemaps configuration ?


Julien REY

Plate-forme RPBS
Modélisation Computationnelle des Interactions Protéines-Ligand (CMPLI)
Université de Paris
tel : 01 57 27 83 95

More information about the lustre-discuss mailing list