[Lustre-discuss] problem with secondary groups

Temple Jason jtemple at cscs.ch
Fri May 25 07:47:27 PDT 2012


I am running lustre 2.1.56 on the server side, and 1.8.4 (cray) on the client side.

I am having the classical secondary group problem, but when I enable it on the mds vi lctl conf_param lustre-MDT0000.mdt.identity_upcall=/usr/sbin/l_getidentity, I still have the same permissions problem on the client.

How do I get l_getidentity to work correctly?  When I run it directly myself using a valid uid,via:

l_getidentity -v lustre-MDT0000 21135

I get no output.

However if I run it with a non-valid uid, like this:

[root at mds1 ~]# l_getidentity lustre-MDT0000 21133
l_getidentity[7805]: no such user 21133
l_getidentity[7805]: partial write ret -1: Invalid argument

Any help would be appreciated.


Jason Temple
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20120525/81804941/attachment.htm>

More information about the lustre-discuss mailing list