[Lustre-discuss] Unable to move MDS using procedure in the manual

Ken Hornstein kenh at cmf.nrl.navy.mil
Tue Jun 4 10:44:44 PDT 2013

I tried to move my MDS from one filesystem on the same machine to another,
using the procedure outlined in the Lustre manuals (I didn't use dd, since
the underlying disks weren't the same size and also I did not think
it was required).

Specifically, I used rsync to copy the files, and also used getfattr/setfattr
to copy over the extended attributes.  Some brief poking around seemed to
show that the EA information made it into the new filesystem.

However, when I went to mount the "new" MDS partition, it failed with the
following error:

May 30 23:36:50 mds-foo kernel: [  186.604083] LustreError: 3082:0:(md_local_object.c:433:llo_local_objects_setup()) creating obj [fld] fid = [0x200000001:0x3:0x0] rc = -116
May 30 23:36:50 mds-foo kernel: [  186.698205] LustreError: 3082:0:(mdt_handler.c:4576:mdt_init0()) Can't init device stack, rc -116
May 30 23:36:50 mds-foo kernel: [  186.797206] LustreError: 3082:0:(obd_config.c:522:class_setup()) setup foo-MDT0000 failed (-116)
May 30 23:36:50 mds-foo kernel: [  186.806140] LustreError: 3082:0:(obd_config.c:1363:class_config_llog_handler()) Err -116 on cfg command:
May 30 23:36:50 mds-foo kernel: [  186.815615] Lustre:    cmd=cf003 0:foo-MDT0000  1:foo-MDT0000_UUID  2:0  3:foo-MDT0000-mdtlov  4:f  

There were more errors, bu they all pretty much were cascading from these
errors.  I switched back to the original filesystem and everything worked.

I am willing to believe I did something wrong, but I'm not sure what; I
did everything the directions said to do.  -116 is ESTALE, and I found
in the code where I believe that error was returned, but it was a little
unclear to me what the root cause was.  Can anyone offer any advice?


More information about the lustre-discuss mailing list