[Lustre-discuss] Lustre build and install on Ubuntu

Grodowitz, Nathan T. grodowitznt at ornl.gov
Wed Nov 5 06:24:39 PST 2014

Hello Mandar,

I recently did some work with 2.6 as a client on ubuntu 12.04. These are some of the steps that were taken below:

apt-get source module-assistant
cd module-assistant

# Get the patches from the following pages
# save detection.patch
# save parsing.patch

patch < detection.patch
patch < parsing.patch

sudo apt-get build-dep module-assistant
dpkg-buildpackage -rfakeroot -us -uc
cd ../
sudo dpkg -i module-assistant-0.14.deb

Then you can take a look at LU-1706<https://jira.hpdd.intel.com/browse/LU-1706>, which explains build script patching that must take place, even on newer versions of Ubuntu.

Once that is done, follow these steps to build the client. For your build, you will want to build the server as well.

cd lustre-release
git checkout v2_6_0
sh ./autogen.sh
./configure --disable-server --disable-iokit --disable-tests
make debs
cd debs
sudo dpkg -i lustre-client-modules-3.11.0-15-generic_2.6.0-1_amd64.deb lustre-utils_2.6.0-1_amd64.deb

Hopefully that helps.

Nathan Grodowitz

On Nov 5, 2014, at 8:10 AM, Mandar Joshi <mandar.joshi at calsoftinc.com<mailto:mandar.joshi at calsoftinc.com>> wrote:

                I have 2 questions regarding building and installing Lustre server on Ubuntu. We have a running Lustre setup on RHEL and now trying to build and install on Ubuntu.

1.       Whether latest Lustre (2.6+) server can be built on Ubuntu with the same steps as for RHEL? Or are there different steps for Ubuntu.
2.       Has anyone tried this before and/or Whether Lustre2.6.x server is supported on Ubuntu.
3.       In another experiment, I took my RHEL working rpms (patched kernel & lustre) and converted them to .deb packages using “alien”. I could install all rpms and then could also boot into my lustre-patched-kernel. I am able to mkfs.lustre my MGS (and even could mount it) But mkfs.lustre for MDT fails.
a.       First it gave errors like “Invalid filesystem option set”. So I installed e2fsprogs-1.42.7.wc1-7.el6.x86_64.rpm and e2fsprogs-libs-1.42.7.wc1-7.el6.x86_64.rpm (which I had used for my RHEL) using “alien”
b.      After this now it gives me another error, “Filesystem has unsupported feature(s) while setting up superblock”. I found similar issue athttps://www.mail-archive.com/pkg-lustre-maintainers@lists.alioth.debian.org/msg00263.html . I am NOT getting message “Your mke2fs.conf file does not define the ldiskfs filesystem type.”. Still tried solution suggested in the next mail, which did not work. Even links for ldiskfsprogs are not working to try. Do I need some other version of e2fsprogs?
Can anyone throw light on this ?

Mandar Joshi
Lustre-discuss mailing list
Lustre-discuss at lists.lustre.org<mailto:Lustre-discuss at lists.lustre.org>

More information about the lustre-discuss mailing list