[Lustre-discuss] Lustre 1.8 client on RedHat 7

Zachary Beebleson zbeeble at math.uchicago.edu
Tue Sep 9 11:11:49 PDT 2014

Just wondering if anyone tried to build a Lustre 1.8 client on a RedHat 7 
system (I believe I saw some chatter about building a Lustre 2+ client on 
el7). I have a legacy Lustre 1.8.4 file system, that I did not chance to 
upgrade to Lustre 2+, and I'd like to mount it on new RedHat 7 computes. 
On a RedHat 6 system a Whamcloud Lustre 1.8.7 client worked, but I was 
not able to get a Lustre 1.8.* Whamcloud rpm to install on RHEL7 --- too 
many old dependencies. I also tried to do a rpm --rebuild, but kept 
getting build errors such as:

cc1: all warnings being treated as errors
make[6]: *** [/root/rpmbuild/BUILD/lustre-2.5.2/lustre/llite/llite_lib.o] 
Error 1
make[5]: *** [/root/rpmbuild/BUILD/lustre-2.5.2/lustre/llite] Error 2
make[4]: *** [/root/rpmbuild/BUILD/lustre-2.5.2/lustre] Error 2
make[3]: *** [_module_/root/rpmbuild/BUILD/lustre-2.5.2] Error 2
make[2]: *** [modules] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.hxvMyD (%build)

RPM build errors:
     Bad exit status from /var/tmp/rpm-tmp.hxvMyD (%build)

both for Lustre 1.8 client source rpms and Lustre 2.5 (on a RHEL7 system).


More information about the lustre-discuss mailing list