[lustre-discuss] Does lustre 2.10 client support 2.5 server ?

Dilger, Andreas andreas.dilger at intel.com
Thu Nov 9 15:13:27 PST 2017

On Nov 9, 2017, at 05:27, Andrew Elwell <andrew.elwell at gmail.com> wrote:
>> My Lustre server is running the version 2.5 and I want to use 2.10 client.
>> Is this combination supported ? Is there anything that I need to be aware of
> 2 of our storage appliances (sonnexion 1600 based) run 2.5.1, I've
> mounted this OK on infiniband clients fine with 2.10.0 and 2.10.1 OK,
> but a colleague has since had to downgrade some of our clients to
> 2.9.0 on OPA / KNL hosts as we were seeing strange issues (can't
> remember the ticket details)

If people are having problems like this, it would be useful to know the
details.  If you are using a non-Intel release, you should go through your
support provider, since they know the most details about what patches are
in their release.

> We do see the warnings at startup:
> Lustre: Server MGS version ( is much older than client.
> Consider upgrading server (2.10.0)

This is a standard message if your client/server versions are more than 0.4 releases apart.  While Lustre clients and servers negotiate the supported features between them at connection time, so there should be broad interoperability between releases, we only test between the latest major releases (e.g. 2.5.x and 2.7.y, or 2.7.y and 2.10.z), it isn't possible to test interoperability between every release.

Cheers, Andreas
Andreas Dilger
Lustre Principal Architect
Intel Corporation

More information about the lustre-discuss mailing list