[lustre-discuss] Not able to load lustre modules on Lustre client

Andreas Dilger adilger at whamcloud.com
Thu Jun 28 23:01:44 PDT 2018

On Jun 28, 2018, at 22:44, vaibhav pol <vaibhavp at cdac.in> wrote:
> Hi,
> I am using the precompiled rpms from site (https://downloads.whamcloud.com/public/lustre/lustre-2.11.0/el7.4.1708/).
> Modprobe is not able to find the lnet module .  Tried  to insert using insmod.
> Following is the  error message.
> cfs_array_alloc (err 0)
> cfs_get_random_bytes (err 0)
> cfs_expr_list_free_list (err 0)
> libcfs_register_ioctl (err 0)
> :
> :

This means that the libcfs module is not loaded.  This should be loaded
on demand as needed.  That implies that "modprobe -ae" is not being run after
module installation, or that the modules are being installed in a directory
that does not match your kernel version.

If you run "rpm -qi kmod-lustre" (or "rpm -qi kmod-lustre-client" if on
the client) it will report which kernel the modules were built for.  This
is also stored in every module, and can be seen with "modinfo lnet" and
"modinfo libcfs" in the "verinfo" field.  This should match the currently
running kernel version reported by "uname -r".

Cheers, Andreas

> On June 29, 2018 at 9:36 AM Andreas Dilger <adilger at whamcloud.com> wrote:
> > It would be useful to include the actual error messages, in particular
> > which module symbols it is complaining about.
> >
> > Cheers, Andreas
> >
> > On Jun 28, 2018, at 22:01, vaibhav pol <vaibhavp at cdac.in> wrote:
> > >
> > > Hi,
> > > I have installed the Lustre client RPMS (Version 2.11.0) on CentOS 7.4
> > > Whenever I tried to insert lnet module it give the unknown symbol
> > > message and not able to load modules. Tried to insert forcefully but
> > > that is also not working.

Cheers, Andreas
Andreas Dilger
Principal Lustre Architect

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 235 bytes
Desc: Message signed with OpenPGP
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20180629/2314c31b/attachment.sig>

More information about the lustre-discuss mailing list