[lustre-discuss] Not able to load lustre modules on Luster client

Patrick Farrell paf at cray.com
Fri Jun 29 05:38:35 PDT 2018

I am not certain, but I believe insmod does not attempt to fulfill dependencies.  What happens when you try modprobe and what are the errors in dmesg then?

From: lustre-discuss <lustre-discuss-bounces at lists.lustre.org> on behalf of vaibhav pol <vaibhavp at cdac.in>
Sent: Thursday, June 28, 2018 11:44:10 PM
To: Andreas Dilger
Cc: lustre-discuss at lists.lustre.org
Subject: Re: [lustre-discuss] Not able to load lustre modules on Luster client


I am using the precompiled rpms from site (https://downloads.whamcloud.com/public/lustre/lustre-2.11.0/el7.4.1708/).
Modprobe is not able to find the lnet module .  Tried  to insert using insmod.
Following is the  error message.

cfs_array_alloc (err 0)
cfs_get_random_bytes (err 0)
cfs_expr_list_free_list (err 0)
libcfs_register_ioctl (err 0)
cfs_percpt_lock_create (err 0)
cfs_restore_sigs (err 0)
lbug_with_loc (err 0)
libcfs_log_goto (err 0)
libcfs_debug_msg (err 0)
cfs_cpt_table (err 0)
cfs_expr_list_print (err 0)
cfs_trace_copyout_string (err 0)
cfs_cpt_current (err 0)
__x86_indirect_thunk_rax (err 0)
cfs_percpt_free (err 0)
cfs_percpt_lock_free (err 0)
cfs_rand (err 0)
cfs_percpt_unlock (err 0)
cfs_percpt_alloc (err 0)
libcfs_log_return (err 0)
lnet_insert_debugfs (err 0)
cfs_percpt_number (err 0)
cfs_expr_list_match (err 0)
cfs_trimwhite (err 0)
cfs_array_free (err 0)
libcfs_kmemory (err 0)
cfs_trace_copyin_string (err 0)
libcfs_deregister_ioctl (err 0)
cfs_srand (err 0)
cfs_block_allsigs (err 0)
cfs_str2num_check (err 0)
ktime_get_real_seconds (err 0)
__x86_indirect_thunk_rcx (err 0)
cfs_cpt_spread_node (err 0)
cfs_expr_list_values_free (err 0)
libcfs_subsystem_debug (err 0)
cfs_expr_list_free (err 0)
cfs_percpt_lock (err 0)
cfs_gettok (err 0)
cfs_expr_list_parse (err 0)
cfs_cpt_of_node (err 0)
libcfs_debug (err 0)
cfs_cpt_weight (err 0)
lprocfs_call_handler (err 0)
cfs_cpt_distance (err 0)
ktime_get_seconds (err 0)
cfs_cpt_number (err 0)
cfs_expr_list_values (err 0)

Thanks and regards,
Vaibhav Pol
Centre for Development of Advanced Computing
Ganeshkhind Road
Pune University Campus
Phone +91-20-25704183 ext: 183
Cell Phone : +919850466409

On June 29, 2018 at 9:36 AM Andreas Dilger <adilger at whamcloud.com> wrote:
> It would be useful to include the actual error messages, in particular which module symbols it is complaining about.
> Cheers, Andreas
> On Jun 28, 2018, at 22:01, vaibhav pol <vaibhavp at cdac.in> wrote:
> >
> > Hi,
> > I have installed the Lustre client RPMS (Version 2.11.0) on CentOS 7.4
> > Whenever I tried to insert lnet module it give the unknown symbol message and not able to load modules. Tried to insert forcefully but that is also not working.

[ C-DAC is on Social-Media too. Kindly follow us at:
Facebook: https://www.facebook.com/CDACINDIA & Twitter: @cdacindia ]

This e-mail is for the sole use of the intended recipient(s) and may
contain confidential and privileged information. If you are not the
intended recipient, please contact the sender by reply e-mail and destroy
all copies and the original message. Any unauthorized review, use,
disclosure, dissemination, forwarding, printing or copying of this email
is strictly prohibited and appropriate legal action will be taken.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20180629/6a962546/attachment-0001.html>

More information about the lustre-discuss mailing list