[lustre-discuss] Lustre-2.10.5 problem

Tung-Han Hsieh thhsieh at twcp1.phys.ntu.edu.tw
Mon Sep 24 05:15:52 PDT 2018

Dear All,

I am trying to install Lustre version 2.10.5 with ZFS-0.7.11
from source code. After compilation and installation, I tried
to load the "lustre" module, but encountered the following

# modprobe lustre
could not load module 'lustre': no such device

My procedure of installation is the following:

1. Compile vanilla kernel 3.12.72 downloaded from:

2. Compile spl-0.7.11 downloaded from:

   with the following steps:
   # ./configure --prefix=/opt/lustre --with-linux=/path/to/linux-3.12.72
   # make
   # make install

3. Compile zfs-0.7.11 downloaded from:

   with the following steps:
   # ./configure --prefix=/opt/lustre \
                 --with-linux=/path/to/linux-3.12.72 \
   # make
   # make install

4. Compile lustre downloaded from:

   Then I unpack the SRPM by the command:
   # rpm2cpio lustre-2.10.5-1.src.rpm | cpio --extract --make-directories

   and compile it by the following:
   # ./configure --prefix=/opt/lustre \
                 --with-linux=/path/to/linux-3.12.72 \
                 --with-spl=/path/to/spl-0.7.11 \
                 --with-zfs=/path/to/zfs-0.7.11 \
                 --with-o2ib=no \
   # make
   # make install

5. I have made sure the following settings and utilities are correct:
   - PATH contains /opt/lustre/bin and /opt/lustre/sbin
   - /sbin/mount.lustre exists.
   - /sbin/mount.zfs exists.
   - /usr/sbin/l_getidentity exists.
   - /usr/sbin/ko2iblnd-probe exists.
   - /etc/modprobe.d/lustre.conf contains:
     options lnet networks=tcp
   - /etc/modprobe.d/ko2iblnd.conf contains:
     alias ko2iblnd-opa ko2iblnd
     options ko2iblnd-opa peer_credits=128 peer_credits_hiw=64 credits=1024 concurrent_sends=256 ntx=2048 map_on_demand=32 fmr_pool_size=2048 fmr_flush_trigger=512 fmr_cache=1
     install ko2iblnd /usr/sbin/ko2iblnd-probe

Then I tried to run "modprobe lustre", it says "no such device" error.

I tried to replace Lustre-2.10.5 by Lustre-2.9 downloaded from:


and proceed exactly the same installation steps. Everything works fine.

Could anyone suggest me what have I missed for lustre-2.10.5 ? Or suggest
me how to debug.

Thanks very much.


More information about the lustre-discuss mailing list