[lustre-discuss] Assistance Compiling Lustre 2.12.2 with ZFS 0.8.1

James Watson James.Watson at pgs.com
Wed Aug 7 12:18:20 PDT 2019


Has anyone got Lustre 2.12.2 compiled with ZFS 0.8.1 on CentOS 7.6? Is there a guide out there?

I've tried: 
./configure --enable-server --with-linux=/usr/src/kernels/3.10.0-957.10.1.el7_lustre.x86_64 --with-zfs=/var//lib/dkms/zfs/0.8.1/source/include --with-spl=/var/lib/dkms/zfs/0.8.1/source/include/spl

Also tried --without-spl support since spl is now integrated in zfs but get the below error message:

checking whether to build ldiskfs... yes
checking whether to enable zfs... yes
checking spl source directory... no
checking spl build directory... ls: cannot access no/[0-9]*/: No such file or directory
Not found
checking zfs source directory... /var//lib/dkms/zfs/0.8.1/source/include
checking zfs build directory... ls: cannot access /var//lib/dkms/zfs/0.8.1/source/include/[0-9]*/: No such file or directory
Not found
checking user provided zfs devel headers...
checking zfs devel headers... -I/usr/include/libspl -I /usr/include/libzfs
configure: error:

Required zfs osd cannot be built due to missing zfs development headers.

The directories source do exist but it's looking for /[0-9]*/ which isn't there since it's the exact location. Also tried not specifying zfs locations and /var/lib/dkms/zfs/0.8.1 but still complains that it can't find the development headers as the directory doesn't exist.


James Watson

More information about the lustre-discuss mailing list