[lustre-discuss] Assistance Compiling Lustre 2.12.2 with ZFS 0.8.1

Shaun Tancheff stancheff at cray.com
Wed Aug 7 12:46:17 PDT 2019


I have never gotten dkms route to work (although I only tried a couple of times).
I do have a working setup for the kmod route.

$ git clone zfs
$ cd zfs
$ git checkout zfs-0.8.1
$ ./autogen.sh
$ ./configure --with-spec=redhat --with-linux=/usr/src/kernels/3.10.0-957.27.2.ldiskfs.el7.x86_64
$ make pkg-utils pkg-kmod
## install the -devel packages: 
## you will now have a /usr/src/zfs-0.8.1/ and /usr/src/spl-0.8.1/

$ <git clone lustre>
$ cd <lustre>
$ git checkout <branch>
$ sh ./autogen.sh
$ ./configure --enable-server --enable-client --with-linux=/usr/src/kernels/3.10.0-957.27.2.ldiskfs.el7.x86_64 --without-o2ib --with-zfs=/usr/src/zfs-0.8.1 --with-spl=/usr/src/spl-0.8.1 --enable-ldiskfs --enable-modules
$ make rpms

3.10.0-957.27.2.ldiskfs.el7.x86_64 is a kernel with 'ldiskfs' support
You can drop the --enable-ldiskfs and use a vanilla kernel instead.

If you are still having trouble I'll do a run sans ldiskfs and send that along.


On 8/7/19, 2:18 PM, "lustre-discuss on behalf of James Watson" <lustre-discuss-bounces at lists.lustre.org on behalf of James.Watson at pgs.com> wrote:

    Has anyone got Lustre 2.12.2 compiled with ZFS 0.8.1 on CentOS 7.6? Is there a guide out there?
    I've tried: 
    ./configure --enable-server --with-linux=/usr/src/kernels/3.10.0-957.10.1.el7_lustre.x86_64 --with-zfs=/var//lib/dkms/zfs/0.8.1/source/include --with-spl=/var/lib/dkms/zfs/0.8.1/source/include/spl
    Also tried --without-spl support since spl is now integrated in zfs but get the below error message:
    checking whether to build ldiskfs... yes
    checking whether to enable zfs... yes
    checking spl source directory... no
    checking spl build directory... ls: cannot access no/[0-9]*/: No such file or directory
    Not found
    checking zfs source directory... /var//lib/dkms/zfs/0.8.1/source/include
    checking zfs build directory... ls: cannot access /var//lib/dkms/zfs/0.8.1/source/include/[0-9]*/: No such file or directory
    Not found
    checking user provided zfs devel headers...
    checking zfs devel headers... -I/usr/include/libspl -I /usr/include/libzfs
    configure: error:
    Required zfs osd cannot be built due to missing zfs development headers.
    The directories source do exist but it's looking for /[0-9]*/ which isn't there since it's the exact location. Also tried not specifying zfs locations and /var/lib/dkms/zfs/0.8.1 but still complains that it can't find the development headers as the directory doesn't exist.
    James Watson
    lustre-discuss mailing list
    lustre-discuss at lists.lustre.org

More information about the lustre-discuss mailing list