[lustre-discuss] lfsck namespace doesn't stop and I cancel it

Yong, Fan fan.yong at intel.com
Wed Jun 26 09:02:33 PDT 2019

If you have no other way to stop the lfsck, then you can try re-mount the MDT with option "-o skip_lfsck".


-----Original Message-----
From: lustre-discuss [mailto:lustre-discuss-bounces at lists.lustre.org] On Behalf Of Fernando Perez
Sent: Wednesday, June 26, 2019 7:59 PM
To: lustre-discuss at lists.lustre.org
Subject: [lustre-discuss] lfsck namespace doesn't stop and I cancel it

Dear lustre users,

I tried to run a lfsck namespace in our lustre filesystem, lustre 2.10.7, and the lfsck never ends and I can't stop it using the lctl lfsck_stop command.

I tried to kill the lfsck process, stop lustre, reboot the metadata server, and when I mount the combined mdt + mgs the lfsck starts again automatically.

How can I stop the lfsck namespace process?

The commands that I runned are the following:

Start the lfsck namespace:

lctl lfsck_query -t namespace -M lustre-MDT0000

Try to stop the lfsck because it never ends:

lctl lfsck_stop -M lustre-MDT0000


Fernando Pérez
Institut de Ciències del Mar (CSIC)
Departament Oceanografía Física i Tecnològica Passeig Marítim de la Barceloneta,37-49
08003 Barcelona
Phone:  (+34) 93 230 96 35

lustre-discuss mailing list
lustre-discuss at lists.lustre.org

More information about the lustre-discuss mailing list