[lustre-discuss] "no space on device"

Lana Deere lana.deere at gmail.com
Thu Mar 19 11:06:19 PDT 2020

I have a Lustre 2.12 setup running on CentOS 7.  It has been working fine
for some months but last night one of my users tried to untar a large file,
which (among other things) created a single directory containing several
million subdirectories.  At that point the untar failed, reporting "no
space on device".  All attempts to create a file on this Lustre system now
produce the same error message, but "df" and "df -i" indicate there is
plenty of space and inodes left.  I checked the mount point on the metadata
node and it appears to have plenty of space left too.

I can list directories and view files on this filesystem.  I can delete
files or directories on it.  But even after removing a few files and a
directory I cannot create a new file.

If anyone can offer some help here it would be appreciated.

.. Lana (lana.deere at gmail.com)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20200319/142995d2/attachment.html>

More information about the lustre-discuss mailing list