[lustre-discuss] ls command blocked in some dir

Franke, Knut knut.franke at atos.net
Wed Sep 23 08:59:52 PDT 2020


we've had a similar issue, though in our case there were "FID-in-LMA
[...] does not match the object self-fid" errors in the OSS logs. See
LU-13392 for details.

You could try disabling auto_scrub (lctl set_param
osd_ldiskfs.*.auto_scrub=0) and check whether this causes lstat() to
return something.


Am Mittwoch, den 23.09.2020, 22:56 +0800 schrieb 肖正刚:
> Caution! External email. Do not open attachments or click links, unless this email comes from a known sender and you know the content is safe.
> Hi, all
>     In one of our lustre filesystems,we found that
>     1) ls command blocked in some dir but ls --color=never  worked.
>     2) some files can not be accessed, like cat/head/vim/file(i use strace to trace command "strace file xxxx.xxx" ,  stucked in lstat). 
>         "
>         fstat(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
>         mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2b02fbb27000
>         mmap(NULL, 266240, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2b02fbb28000
>         lstat("animation-2_0043.hsf", 
>         "
>     3) at the same time,no message found on client/mds/oss
> Are these files corrupted? How to repair?
> PS: We have used lfsck,not worked and we cannot bring down the filesystem to run e2fsck at present.
> _______________________________________________
> lustre-discuss mailing list
> lustre-discuss at lists.lustre.org
> http://lists.lustre.org/listinfo.cgi/lustre-discuss-lustre.org

More information about the lustre-discuss mailing list