[lustre-discuss] Unable to mount new OST

Andreas Dilger adilger at whamcloud.com
Mon Jul 5 22:07:54 PDT 2021

On Jul 5, 2021, at 09:05, David Cohen <cdavid at physics.technion.ac.il<mailto:cdavid at physics.technion.ac.il>> wrote:

I'm using Lustre 2.10.5 and lately tried to add a new OST.
The OST was formatted with the command below, which other than the index is the exact same one used for all the other OSTs in the system.

mkfs.lustre --reformat --mkfsoptions="-t ext4 -T huge" --ost --fsname=local  --index=0051 --param ost.quota_type=ug --mountfsoptions='errors=remount-ro,extents,mballoc' --mgsnode= at tcp --mgsnode= at tc
p --mgsnode= at tcp --servicenode= at tcp --servicenode= at tcp --servicenode= at tcp /dev/mapper/OST0051

Note that your "--index=0051" value is probably interpreted as an octal number "41", it should be "--index=0x0051" or "--index=0x51" (hex, to match the OST device name) or "--index=81" (decimal).

When trying to mount the with:
mount.lustre /dev/mapper/OST0051 /Lustre/OST0051

The system stays on 100% CPU (one core) forever and the mount never completes, not even after a week.

I tried tunefs.lustre --writeconf --erase-params on the MDS and all the other targets, but the behaviour remains the same.

Cheers, Andreas
Andreas Dilger
Lustre Principal Architect

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lustre.org/pipermail/lustre-discuss-lustre.org/attachments/20210706/e6747ff3/attachment.html>

More information about the lustre-discuss mailing list